Answered question

Response code NL-NETWORK-01, when using the POST method in the API tests

I am sending the followint POST command:

User-Agent: Jetty/9.3.7.v20160115NeotysEdition.61
Content-Type: application/json
Content-Length: 174

{"id": 1257, "username": "Uname4", "firstName": "FName5", "lastName": "LName6", "email": "",
"password": "user12347", "phone": "9944556633", "userStatus": 0}

This response I will get:

Error detected by NeoLoad
Error Code: NL-NETWORK-01 Message: Network error: An IO error occurred sending the request.
Details: protocol_error

Error while initializing client certificates toDerInputStream rejects tag type 45

I have done the following:

In the NL preferences I am using certificate NeoLoad_Root_CA.cer for both recording and runtime.

Is something still missing?

Timo H.
Timo H.

Timo H.

3 / 100

I tried to execute the same request and it worked on my side. Do you use a proxy to reach that URL?

Could you try to disable HTTP/2 in the Advanced settings of the check vu panel to see if you get a different errors?

Also one of the error message is related to client certificate. Did you get that error at the same time for the same execution?

Look at the NeoLoad prefrences under Project settings tab --> Certificate manager to make sure that on the Runtime area of that panel you have "No certificate" selected.

Did you find this useful ?

No (0)

Yes (1)


100% of users found this answer useful

Other answers