Answered question

I got this error after a new recording " Received fatal alert: bad_record_mac". Why?

I made a new recording of my new HTTPS application with NeoLoad but received the error above. Of Note:  I don't have this issue outside of the NeoLoad application.

How can I get rid of that error?

When you record with NeoLoad, there will be the NeoLoad proxy between your browser and your application server.  For HTTPS applications, you can have different SSL versions that can be used for the SSL handshake.

By default, NeoLoad will use the SSLv2 version. But some Servers only accept SSLv3 version and so this can cause some errors like the one you've encountered.

In that case, you can configure NeoLoad to specifically use the SSLv3 for the handshake.

Here is the procedure:

  1. Stop NeoLoad
  2. Edit <install_dir>\conf\
  3. Go to [General] section and locate that key below:
  4. Remove the two options in order to keep only SSLv3 like below:
  5. Save
  6. Start NeoLoad

Now your NeoLoad recording should correctly work.

Did you find this useful ?

No (1)

Yes (0)


0% of users found this answer useful