Unanswered question

Neoload 6.6 > Request parameter is encoded automatically by Neoload ?

Hi,

I encountred a problem when I validate a recorded script. In fact, in the record phase, I have this request parameter :

{%22type%22%20:%20%22...%22tsp%22:1537192577036}]}

and when I validate the script, I got a 404 error and this parameter was encoded and changed by this one :

%7B%2522type%2522%20%3A%20%2522...%2522tsp%2522%3A1537192577036%7D%5D%7D

Please note that when I execute the URL manually with the first parameter, I get the true result and not with the second one.

Note also that in the request parameter, the option "Encoder" is not selected.

Do you have an idea please ?

Regards,
Sofiane

Sofiane B.
Sofiane B.

Sofiane B.

Level
1
101 / 750
points

Answers

Antoine M.
Antoine M.

Antoine M.

Level
1
174 / 750
points

Hello, same problem here...
So, I ask the same question.

Regards,
Antoine

Some characters are unsafe in the value and NeoLoad has to encode them whatever the option checked or not. The NeoLoad HTTP client does it by default.

The issue here is some of the values are encoded twice. So if you replace your recorded value by "{"type" : "..."tsp":1537192577036}]}" (nothing is encoded) NeoLoad will send the whole value encoded and in that case the server should accept it.

Could you try that?