Unanswered question

Neoload not able to record but Fiddler is able to record ?

My application is preprod and uses SSO(Single Sign On) to move forward. When Neolaod changes the proxy to localhost:8090, then my application doesnt accept my username & password(I think its because of the proxy changed by neoload). If I dont use the neoload proxy, then i my application moves forward with no issues, but neoload doesnt record anything.

I used Fiddler and it was able to record everything with

Is there any other way. Please help me out.


When you start a NeoLoad recording the browser proxy settings are modified to "localhost:8090" which is normal since it's how NeoLoad can record your application.

What kind of authentication do you get when recording with NeoLoad? Is it a pop-up from Windows? What is the content of that pop-up?

What happens if you reach your application without NeoLoad but from Firefox. Do you still get an authentication pop-up?

@Nouredine - let me further explain my issue, My application has the url "https://preprod.example.com";. when i trigger the URL, I am prompted for username on the site itself, when i enter my username and hit signin button, it then gives me a poup up, coming from "https://adfs.mycompany.com";, asking for my SSO username & password.

When i use any normal browser(IE,FF,Chrome) when there is no proxy set, I enter my credentials and the popup goes away and I land on my home page. No problem here

When i use fiddler, it changes the proxy to "", I am able to record everything and after entering my credentials, the popup goes away and I land on my home page. No problem here

Now, when i use Neoload, I am able to record til I am asked for my username, but then when the popup asking my SSO username & password appears, it doesnt go away even after entering my valid credentials.It keeps popping up 2-3 times.

I have tried to do the setting in firefox of bypassing the popup by including both the URL's(https://preprod.example.com,https//adfs.mycompany.com) in "network.automatic-ntlm-auth.trusted-uris" in about:config, but it still asks for username & password at the time of recording. Tried the same thing with trusted sites in IE & chrome.

Please find attached the screenshots.

During the NeoLoad recording you should see your request against that "adfs" server. If you look at the recorded response what do you see?

If it's an HTTP 401 response could you copy/paste the whole header content?

Still in NeoLoad Design section you should see that "adfs" server in the server list. Do you see any credential set in the server definition?

What is the syntax of the credential? In other words do you have the domain column filled or your login column contains your domain like this: DOMAIN\username?

@Nouredine - The thing is adfs server popup doesnt move forward after entering valid credentials, so there is nothing recorded in neoload.

Also, no credentails are saved in server list for adfs server.

Please see the screenshot attached.

Daniel L.
Daniel L.

Daniel L.

12 / 100


Was a resolution found for this? I am experiencing the same issue.