Unanswered question

Unexpected License Error During NeoLoad NoGui Run

Hey Guys,
We are currently running NeoLoad everyday as part of our pipeline. We are using NeoLoads Awesome NoGui Mode to do this which gets the job done very well. But I encounter an unexpected error with my Run of today. I got the following error:

Loading project: D:\test\Neoload projects\10052019_GPSRegressie\10052019_GPSRegressie.nlp
Project 10052019_GPSRegressie loaded
ERROR: The number of Virtual Users in the Scenario exceeds the license limitation.
com.neotys.nl.g.R: Issues Detected Before Executing Scenario "GPS Regressie Test"
at com.neotys.nl.g.F.a(F.java:391)
at com.neotys.nl.g.F.a(F.java:546)
at com.neotys.nl.g.F.a(F.java:416)
at com.neotys.nl.controller.Controller.a(Controller.java:1910)
at com.neotys.nl.controller.Controller.launchScenario(Controller.java:1773)
at com.neotys.nl.launcher.ControllerLauncher.main(ControllerLauncher.java:289)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:65)
at com.exe4j.runtime.WinLauncher.main(WinLauncher.java:101)
at com.install4j.runtime.launcher.WinLauncher.main(WinLauncher.java:26)
Exit with status: 2

At first I thought there was a problem with my script so I tried re-running my script and it worked perfectly.
Because of the following error: "ERROR: The number of Virtual Users in the Scenario exceeds the license limitation." I thought there might be a problem with my license server but this one was up and running the entire time.

Can you please help me understand what could have gone wrong? So I can try to prevent it from happening again.

Thanks :).

Joey H.
Joey H.

Joey H.

20 / 100


It's not the complete trace but you mentionned a license server so i guess that you should have in the output a line related to the lease of your license right? did it succeed and was it the right number of users leased compared to the number of users that is configured in your populations?

Also do you mean that running again the same script worked the second time?



Joey H.
Joey H.

Joey H.

20 / 100

Hey Nouredine,

Below you can find the complete output:

NeoLoadCmd.exe -project "D:\R.A.F\Neoload projects\10052019_XXXRegressie\10052019_Regressie.nlp" -launch "Regressie Test" -n\
oGUI -exportRaw "\\wsv11111\R.A.F\01_test_regressie_20192506__ 4h00min.csv" -leaseLicense "Licence_Key_Here\
Logging to C:\Users\XXX758L6\AppData\Roaming\Neotys\NeoLoad\v6.6\logs, as user: XXXB758L6
Found a valid NTS configuration : URL=[http://wsv11122:8080//] and USER=[wsv11145]
Leasing license Licence_Key_Here/o/qw==...
Leased license Licence_Key_Here/o/qw== with 100 web, 0 SAP VUs for 120 minutes(s).
Loading project: D:\R.A.F\Neoload projects\10052019_Regressie\10052019_Regressie.nlp
Project 10052019_Regressie loaded
WARNING: File not found in Variable "FV_XXX"
WARNING: File not found in Variable "FV_XXX"
WARNING: File not found in Variable "XXXXX_KlantIDs_Docs"
WARNING: The NeoLoad API server was not started. See logs for details.
Launching scenario: GPS Regressie Test (01h:02m:00s)
Initializing Monitors...
You have reached the maximum number of Virtual Users for this license.

Stopping Monitors...

Yes Neoload leased the right amount of users but in the middle of our test it just crashes. No other test runs with that license at that time so no other test could interfering with this test.

When I run the script manually during the day I encounter no issues with this.

Stijn S.
Stijn S.

Stijn S.

23 / 100

Hi Nouredine,
This issue is still occuring. I believe the error provided by Neoload is not correct. The automated test that we run overnight executes ok but sometimes the test ends with the error stated below. This prevents us to use NeoLoad in a continious delivery pipeline. Can I ask you to look into this issue with a higher priority? Thanks for your understanding,
Stijn Schepers

Neil W.
Neil W.

Neil W.

5000 / 5000

The error refer to there not being 100vu left on the licence server for you to use. You are trying to request 100 and they aren’t there. Could there be another test running at the same time that takes the users before you get there? You should check your NTS logs