Answered question

I configured NLS 3.0 to use my Active Directory (AD) repository but it does not work. What could be the root cause?

I have modify the security file in NLS configuration, the test of connection is working but when I try to get a license I can't see my 4.1 licenses. Why?

Since NeoLoad 4.1, you have to use credentials to connect to a NLS 3.0 server. There are 3 types of credentials that you can use.
You can create local credential with the password in clear text, or encode the password with a third tool called “password scrambler”. And, the last way is to connect to an AD/LDAP directory.

If the test of connection worked that means that the credential provided to connect to your AD/LDAP are correct.

There's multiple reasons to not see any licenses available from NeoLoad:

1. By default, there's a filter of 50 Virtual users. Try to increase it until the maximum amount of users.
2. Your AD request may not return anything or not have the right group.
In that case you can enable a debug trace in the NLS to see the result of your AD request.


1. Stop NLS service
2. Edit <install_dir>\conf\nlslogs.xconfig
3. Add this category at the end of the file:

<category name="org.apache.shiro.realm.activedirectory.ActiveDirectoryRealm" log-level="DEBUG">  <log-target id-ref="logFile"/>  </category>
4. Save and start the NLS service

From NeoLoad, try to connect to that NLS.

Then, to get the NLS server logs it depends on your OS and how you've started the NLS (through the service or manually).

Under Windows Seven/2008 64 bits:

Under Windows XP:
C:\Documents and Settings\<USERNAME>\Local Settings\Application Data\Neotys\NLS\

Under Unix/Linux:

The debug information will be stored in that file "nls.log.000001".
Check whether the AD request for the group worked.

Don't forget to reverse back the debug information when it's finished.

For more information, see “Security” section in NLS  documentation.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful